Top 1,000 Features Creators Events Podcasts Extensions Blog Explorer CSV Download

1C Enterprise Script

< >

1C Enterprise Script is a programming language created in 2002.

#966on PLDB 22Years Old 39kRepos

The 1C:Enterprise platform allows for business oriented application development. The software allows work in thick, thin and web clients.[21] It also supports creating mobile applications for Android and iOS in the same environment using the 1C programming language


Example from hello-world:
Message("Hello World");
Example from Linguist:
Каталог = ОбъединитьПути(ТекущийКаталог(), "libs\oscript-library\src"); Загрузчик_Оригинал_ИмяФайла = ОбъединитьПути(Каталог, "package-loader.os"); Файлы = НайтиФайлы(Каталог, , Ложь); Для Каждого ВыбФайл Из Файлы Цикл Если ВыбФайл.ЭтоФайл() Тогда Продолжить; КонецЕсли; Загрузчик_ИмяФайла = ОбъединитьПути(ВыбФайл.ПолноеИмя, "package-loader.os"); Загрузчик_Файл = Новый Файл(Загрузчик_ИмяФайла); Если Загрузчик_Файл.Существует() Тогда Продолжить; КонецЕсли; КопироватьФайл(Загрузчик_Оригинал_ИмяФайла, Загрузчик_ИмяФайла); КонецЦикла;

Language features

Feature Supported Example Token
Strings
"Hello world"
"
Print() Debugging Message

View source

- Build the next great programming language · About · Resources · Acknowledgements · Part of the World Wide Scroll